From: Marion Gunn (firstname.lastname@example.org)
Date: Mon Jul 27 2009 - 04:00:19 CDT
Scríobh Asmus Freytag:
> On 7/26/2009 2:03 PM, karl williamson wrote:
>> I'm trying to come up with an alias to propose to the UCT
>> for the misleadingly named Age property. People tend to think from
>> the name that Age=3.2 means that the code point dates to version 3.2,
>> when in fact it means it dates to at least 3.2.
>> There are a couple of things which make this hard.
> The first of them is that Unicode does not rename properties, once
> they have been published. (Names for properties newly introduced in a
> beta are fair game, but this one's been around).
> At best, Unicode could introduce *another* name (aka "alias") for the
> property. This is something that gets done sparingly, for obvious
> reasons, since it could lead to confusion. Usually, only a short and a
> long name are created for a new property.
> So, you'll need to demonstrate that the problem with this name is at
> least as bad, if not worse, for those of any other existing property,
> and second, the new alias will need to be a definite improvement.
> Finally, it should be related to the existing alias (which will
> _continue to exist_ after all), so that users will get the connection.
>> One is that the term "assigned" (and its antonym, "unassigned") has a
>> somewhat different meaning here than usual, which is that permanent
>> non-characters are considered assigned here, but not elsewhere.
>> Thus, Age=Unassigned includes a different set of code points than
>> General_Category=Unassigned, the difference being the
>> non-characters. I think there should be a different term for the Age
>> version. I think Age=None would be good.
> Now you are asking not only for a new alias for the property, but also
> for a new alias for one of the _values_ of that property. That's a
> separate proposal in an of itself. I think "Age=Unassigned" can mean
> "no age has been assigned", which fits nicely. By the way, there's
> never been a requirement to have the property values have unique names
> across different properties. Each property effectively creates its own
> namespace for the identifiers of property values. For example, all
> Boolean properties use the values Y and N, yet the ranges for which
> these apply are different.
>> The other problem is that, say, the alias "Assigned_In=4.0" could
>> mean either already there in 4.0, or 4.0 introduced it. A verb that
>> is more passive would be better.
>> I have some possibilities, but would like some more:
>> In=2.1 or In_Version=3.0
>> Known_To=5.1 or Known_In, Known_In_Version, Known_To_Version
>> I've looked at thesauruses, and there are words like allotted,
>> allocated, but again they're too active, and don't convey the
>> non-characters; the best I think so far is In_Version.
> The problem with "age" is that in real life it connotes an ever
> changing number counting the units of time since something came into
> being. As used for this property, it really means "birthdate" or
> "birth-version", i.e. the fixed point in time something was added to
> the standard.
> So, "Version_for_which_added" or "Earliest_Version" would have been
> better names for that property because they conform to the readers
> expectations by designating a point in time, or, if not actual time,
> then a place in a succession of versions.
> Now, there's a special situation with the "age" property, and that is
> that its short and long alias are identical (except for casing, which
> doesn't count). So, Age really doesn't have a long alias. That would
> allow for the possibility of creating a new long alias, for which
> "age" is an abbreviation. Something like
> "AssiGnedEarliest", hence A.G.E or age.
-- Marion Gunn * eGteo (Estab.1991) 27 Páirc an Fhéithlinn, Baile an Bhóthair, An Charraig Dhubh, Co. Átha Cliath, Éire/Ireland * email@example.com * firstname.lastname@example.org *
This archive was generated by hypermail 2.1.5 : Mon Jul 27 2009 - 12:16:20 CDT