From: karl williamson (email@example.com)
Date: Sun Jul 26 2009 - 16:03:57 CDT
I'm trying to come up with an alias to propose to the UCT for the
misleadingly named Age property. People tend to think from the name
that Age=3.2 means that the code point dates to version 3.2, when in
fact it means it dates to at least 3.2.
There are a couple of things which make this hard. One is that the term
"assigned" (and its antonym, "unassigned") has a somewhat different
meaning here than usual, which is that permanent non-characters are
considered assigned here, but not elsewhere. Thus, Age=Unassigned
includes a different set of code points than
General_Category=Unassigned, the difference being the non-characters. I
think there should be a different term for the Age version. I think
Age=None would be good.
The other problem is that, say, the alias "Assigned_In=4.0" could mean
either already there in 4.0, or 4.0 introduced it. A verb that is more
passive would be better.
I have some possibilities, but would like some more:
In=2.1 or In_Version=3.0
Known_To=5.1 or Known_In, Known_In_Version, Known_To_Version
I've looked at thesauruses, and there are words like allotted,
allocated, but again they're too active, and don't convey the
non-characters; the best I think so far is In_Version.
This archive was generated by hypermail 2.1.5 : Sun Jul 26 2009 - 16:08:32 CDT